How to Ungroup in Illustrator

Adobe Illustrator has a variety of features that make it easy to simplify your design workflow, including Group and Ungroup. Essentially, these options allow you to consolidate complex graphics — which are often created with many different shapes — as a group, and then uncouple objects from the group as you see fit. Below, we've shared a practical guide to Illustrator's Group and Ungroup features, so you can speed up the creative process for a logo, illustration, or cartoon. 

The Basics of Grouping 
First, launch the Illustrator project that you'd like to group. Before learning how to ungroup in Illustrator, it's a good idea to learn how the basic Group function works. 

If you're working with a variety of different shapes and objects, it's easy to select them all. Just choose the Selection tool from the main toolbar, click on one of the objects, and then hold down the Shift key while clicking on a second object. This adds it to your current selection.  

When you're ready to group the selection, press CTRL+G (Command+G on Mac). Then, choose "Select" > "Deselect" from the top menu bar and click on one of the objects you just grouped. Automatically, both objects will be selected. Next, hold down the Shift key again and click on a third object. Then press CTRL+G to group the three objects. 

As you do this, Illustrator keeps track of the order that you choose to group objects. To reverse-engineer the grouping process at any point, you can choose "Select" > "Deselect" to deselect the group, choose the Direct Selection tool, and then click on the first object in your group. Clicking once only selects the first object, but clicking again adds the second object to your selection, and clicking a third time will add the third object. 

If you like, you can also create "nested" groups, which are essentially groups within groups. Just look for the "<Group>" items located in the Layers panel, and then move individual objects between the various groups by simply dragging with your mouse.    

How to Ungroup in Illustrator
Once you get the hang of grouping, you've essentially learned how to ungroup as well. Simply click on a grouped object with the Selection tool, and then choose "Object" > "Ungroup", or use the keystroke CTRL+Shift+G (that's Command+Shift+G on Mac). If you previously performed more than one group function to create your finished group, you may need to select "Ungroup" more than once to get the job done. 
 
  • Was this article helpful?

Can’t find what you’re looking for?