Need vectors for a project?
Shutterstock has millions and is constantly adding more. Explore our plans today.
Explore Now

How To Remove White Background in Illustrator

When working with .jpeg images in Illustrator, you might want to remove the white background without affecting the colors and shapes around it. Whether you’re working on a professional business design or a personal project, here are some steps you can take to painlessly remove white background in Illustrator.
 
Step-by-Step Guide to Removing White Backgrounds
 
  1. Open Adobe Illustrator.
  2. In the “File” menu, select “Open,” then find the .jpeg file you want to remove the white background from.
  3. Go to your “View” menu, then select “Show Transparency Grid”. This will allow you to see if you’re successfully changing the white background on your .jpeg file to transparent.
  4. Go to your “Window” menu, then select “Image Trace”.
  5. Create a trace to remove the image’s white background by making the following settings adjustments in your Trace window:
  6. Preset: Keep it at its default setting to start with (you’ll change it later)
  7. View: Set to Tracing Result
  8. Mode: Change to Color
  9. Palette: Select Full Tone
  10. Advanced: Expand so all options show, but leave all options at their default setting except for Method
  11. Method: Select Abutting (the left-most option)
  12. Once you have adjusted your settings as specified, you can select “Preview” to view the new settings and see how they change the image.
  13. Review your image to make sure the white background has successfully been removed.
  14. Save the file in PNG, GIF, TIFF or BMP formats using the Save for Web option or Export the file as a PNG.
If you successfully complete all of the above steps, the file will open without the cumbersome white background.
 
Tips for Saving Illustrator EPS Files
 
If your EPS background is opaque, it will appear white when you save your file. You can avoid this problem by saving your EPS files with transparent backgrounds instead of white backgrounds. Here’s how:
 
  1. Open the problematic EPS file (with the opaque/white background) in Illustrator.
  2. Make and save a copy of the file, but preserve the original. You can do this by choosing File > Save As, then renaming the copied file and changing its background setting to transparent. Use a name that will remind you the file has a transparent background.
  3. Change the file format to “EPS”
  4. Click “Save,” then open the dialog box labeled “EPS Options.
  5. Select “Transparent” from the options in the dialog box.
  6. Click “OK”.
Now that you know how to remove white background in Illustrator, you can further improve your designs by adding high-quality stock images from Shutterstock. Find the perfect images for your projects by filtering your results by genre, size or keywords.
 
 
  • Was this article helpful?

Can’t find what you’re looking for?