How to Make Patterns in Photoshop

Learning how to make patterns in Photoshop is simple, and the powerful editing software allows you to stitch them together like wallpaper, or even paint with them using a  brush. Below, we've outlined the essential steps for editing, wrapping, and saving patterns for later use.  


Need images for your project? Shutterstock’s impressive collection of more than 70 million images can help! See what our library has to offer.


How to Make Patterns in Photoshop (Basic)

  1. First, load a new Photoshop project by selecting "New" from the File menu. This blank canvas will eventually become our saved pattern, so choose image dimensions that aren't too large for the job. Around 100 x 100 pixels is a good starting point, but you can always update the dimensions to your liking. Make sure to zoom in by clicking the "+" button, so that the canvas fills most of the screen. 

  2. To create a simple pattern, just fill in the canvas with whatever shapes, text, and imagery you like. You can use multiple layers, but just make sure to right-click on them and select "Flatten Image" when you're ready to save them together. For more exact patterns, go to the View menu and select "Show Guides". This will help you measure and align objects on your canvas.  

  3. When you're ready to save your pattern, go to the main Edit menu and select "Define Pattern". A new dialog box will appear, allowing you to name the pattern. Click "OK", and your creation will be saved within the patterns menu, which you can access at any time.  

Creating Complex and Seamlessly Repeating Patterns

  1. Start by opening a new Photoshop project, and then placing the images you want on the canvas, just like you would with a basic pattern. Then, merge all of your layers by right-clicking on the Layers panel and choosing "Flatten Image". 

  2. Next, we're going to offset the image so that it fills up the canvas' corners, allowing it to seamlessly repeat. Go to the main Filter menu, click "Other", and then "Offset". In the Offset dialog box, you'll want to set the Horizontal Offset to zero, the Vertical Offset to half of your canvas height (ex. if it's 100 pixels, set it to 50), and then check the Wrap Around box. Then click "OK". 

  3. Now, you're going to return to the same Offset filter ("Filter" > "Other" > "Offset") and adjust the Horizontal Offset setting. Just like you did with the Vertical Offset, you should set the Horizontal Offset to half of the canvas' width. 

  4. If the corners still don't seem to line up, you can go back to the Offset filter one last time and adjust the Vertical Offset. Use the same approach as before — if the canvas height is 200 pixels, set the Vertical Offset to 100 pixels. Leave the Horizontal Offset at zero, keep the Wrap Around box checked, and click "OK".

  5. Before saving your project, open a new canvas (it should be much larger than the pattern) and test how the pattern actually looks. Then, go to the Edit menu, select "Fill", and choose "Pattern" from the dialog box. Now you'll be able to use the Pattern Stamp Tool (located under the Clone Stamp Tool in the main toolbar) to paint the pattern so that it blends together into a seamless design.

  • Was this article helpful?

Can’t find what you’re looking for?