How to Make a Table in InDesign

In this walkthrough, we've shared how to make a table in InDesign, so you can organize data in intelligent and elegant ways. Whether you're working on an infographic for a brochure, or a list of statistics for a newspaper story, you can use tables for a wide variety of applications. 

How to Make a Table in InDesign
1. First, load your current InDesign project, or start a new one by double-clicking on the program icon and selecting "File" > "New" > "Document". 

2. Then, choose the Type tool from the Tools panel (or press the T key) and click on the section of your project where you'd like to add a table. Choose "Table" > "Insert Table" on the menu bar (or press Ctrl+Alt+Shift+T) to place a table at the selected location. 

3. An Insert Table dialog box will appear, allowing you to set the rows and columns for your table. You can also specify the number of Header Rows and Footer Rows, which repeat at the top or bottom of every column. When you're happy with the settings, press OK.    

How to Add Text and Images to a Table
Choose the Type tool, click on the cell where you'd like to add text, and start typing. You can also copy text from a different source using the Ctrl/Cmd+C keystroke, and then paste it into a cell using Ctrl/Cmd+V (or go to "Edit" > "Paste").

Finally, you can place text from a file by clicking on the desired cell, selecting "File" > "Place", and then locating the file on your hard drive. Once you've added text to your table, it's easy to adjust the font, size, and color by highlighting it with your cursor, and then adjusting settings in the control panel.   

To import images into your table, first select the section where you'd like the image to go, and then choose "File" > "Place" from the main menu. Find the image file on your hard drive and double-click on it. 

How to Format an Existing Table 
At any point in the creative process, you can resize your table by selecting any rows or columns, and then choosing "Table" > "Cell Options" > "Rows and Columns". This will launch a Table Options dialog box, with settings like Table Dimensions, Table Border, and Table Spacing. Meanwhile, if you'd like to apply a background color to a particular section, select it and then choose "Table" > "Cell Options" > "Strokes and Fills".   

  • Was this article helpful?

Can’t find what you’re looking for?