How to Import Layers in Photoshop

Thankfully, Adobe Photoshop allows you to copy layers between images with relative ease, including your Background layer. Before copying anything, though, remember that your destination's resolution will dictate how large the copied layer will be. If the final destination has different pixel dimensions, then the copied layer will change size to match those dimensions. Below, we've outlined how to import layers in Photoshop, so you can harness the best ideas from previous projects. 

1. First, open the two Photoshop files that you want to copy layers between. Then, go to the Layers panel for the source image, and click on the layer that you want to import. 

2. With the layer selected on the list, go to "Select" > "All" to make sure that every pixel in the layer is selected, and then select "Edit" > "Copy" to copy the layer. Then, click on the destination image to select it, and choose "Edit" > "Paste" on the top menu. You can also drag the source layer from the Layers panel directly onto the destination.

3. By default, the imported layer is pasted above the currently active layer in the destination file, and this is reflected in the Layers panel as well. If the imported layer is larger than the destination, however, the sections that stretch beyond the image boundaries will not be visible. 

4. Click on the imported layer with the Move tool to reposition it by hand, or hold Shift while dragging to move the layer to the exact center of your image. If the source image and destination image have the same dimensions, holding Shift while dragging with the Move tool will bring the layer back to its original position. 

  • Was this article helpful?

Can’t find what you’re looking for?