How to Create an Adobe Premiere Slideshow

In this walkthrough, we've shared how to create an Adobe Premiere slideshow using the same tools and effects for video editing. Premiere might seem like an intimidating program for building slideshows, but once you grasp the basic layout, you just need to drag and drop content into the timeline.  

Preparing Your Project  
First, start a new Premiere project and give it a name. Then go to "File" > "Sequence" to specify the quality of your slideshow. For most purposes, the options in the HDV tab are ideal for today's HDTVs and computer monitors. Whether you choose 24, 25, or 30 frames per second is up to personal preference. 

Importing Your Photos
Next, you need to tell Premiere where to find your photos, so you can drop them into the slideshow. Go to "File" > "Import" (or press Ctrl+I) to launch a file directory, and then double-click on the photo folder. You can also hold the Ctrl key (Command on Mac) and click on multiple folders to select them, and then press the "Import" button. 

Your photo folder should appear in the Project Window; click on the drop-down arrow next to the folder to view the full list of photos. Any videos located in the folder will also appear in this window.

Choosing Your Transitions
To set up your default slideshow transition, select the Effects tab (it should be in the bottom left quarter of your project) and click on the drop-down arrow for "Video Transitions". You'll see a variety of transitions here, from Film Dissolve to Cross Zoom. 

Right-click on your preferred transition and choose "Set Selected as Default Transition". Now, any photos you drop into the timeline will be introduced with your chosen transition.

Selecting Photos & Videos
Next, go back to the Project Window and start Ctrl+clicking (Command+clicking on Mac) on the content that you'd like to add to your slideshow. Then click on the tiny icon located to the right of the words "Project: [Name]" in the same window, and choose "Automate to Sequence". 

An Automate to Sequence dialog box will appear, with settings for the slideshow order, transitions, and more. Make sure that the "Apply Default Video Transition" box is checked, and then click OK. All of your selected photos and videos will now appear in the timeline, with a default transition in between each file. To change any individual transition in your timeline, go back to the Effects tab, find a transition that you like, and simply drag it over the transition that you want to replace. 

Adjusting the Photo Sizes
Typically, not all of your photos will be optimized to fill your sequence window, but this is easy to adjust. Click and drag a box around your photos to select them, right-click on any of the clips, and choose "Scale to Frame Size" from the options menu. Now, all of your photos will be scaled to fit perfectly in the frame. 

Adding Music
Finally, you can load music into your Adobe Premiere slideshow by going to "File" > "Import" and choosing a song from the file directory. When you click the "Import" button, your song will be loaded into the Project Window. From there, you can drag and drop the file into your timeline's audio track. 
 
  • Was this article helpful?

Can’t find what you’re looking for?