How to Create a Logo in Illustrator

In this practical guide, we've shared how to create a logo in Illustrator using vectors that can be printed at any size, without losing quality. With a well-conceived logo, your business will have a symbol that represents its mission statement and core values.

Preparing Your Project
1. First, start a new Illustrator project by choosing "File" > "New", and then enter a name for your file. Make sure that "Print" is selected in the Profile section, and "Inches" is selected for the Units (or "Centimeters" if you're on the Metric system). Then, click OK. 

2. Before you start designing the logo, we recommend resetting your Illustrator panels by clicking your current workspace (ex. "Essentials") in the top right corner, and then choosing "Reset [current workspace]". This allows you to start the creative process with default panel settings. We also recommend selecting "View" > "Fit Artboard in Window" so you can see the entire project at all times. 

3. When brainstorming your logo, we recommend searching for reference images on Shutterstock or Google, just so you have some initial material to work with. For example, if you're designing a logo for a music PR agency, you might want to start with a photo of headphones or a vinyl record. You can place the reference image on your artboard by selecting "File" > "Place", and then double-clicking on the image file. 

4. Next, you can start to figure out how many simple vector shapes it will take to create a logo version of your reference image. For a vinyl record, you'll just need two circles, and maybe a third circle for the label section. 

5. To get started, choose "Window" > "Layers" to open the Layers panel, and then click the "Create New Layer" icon (it looks like a folded page) to create your first logo layer. Double-click on your new layer to rename it, and then click once on the layer to select it. 

How to Create a Logo in Illustrator
1. Using a combination of shape tools (such as the Rectangle, Ellipse, and Polygon), you can create virtually any vector shape that you need. Click and hold the mouse button on the Rectangle tool to show the other shape tools. 

2. Click and drag on the artboard to draw a new shape. At any point in the creative process, you can resize or rotate individual shapes by dragging on their corner points, or round the corners by dragging on the little circles (called radius widgets) inside the shapes. 

3. If you need flexibility to draw a more complex shape, try using the Curvature tool (it looks like a pen with a curved line). Click once on the artboard to set a point, and then click again to draw a curved path between the two points. Then, continue clicking until the path is completed. If you hold the Alt key (Option on Mac) while doing this, the Curvature tool will draw straight paths between points. 

4. You can fill a shape with color by selecting it (click on it with the Selection tool), and then clicking the Fill swatch in the top-left section of the tool control panel. In this panel, you can also adjust the shape's stroke color, thickness, and much more. 

5. Lastly, if you want to add text to your logo, choose the Type tool (it looks like a T), and then click on the artboard to create a text prompt. Enter your text, and then adjust the font, color, and other settings in the control panel. Once you're happy with the logo, make sure to press Ctrl+S to save your work. Then, save the logo to your Creative Cloud library by dragging it into the Libraries panel with the Selection tool.

  • Was this article helpful?

Can’t find what you’re looking for?