How to Convert a PSD to InDesign

Adobe is known for its rich software suite, which includes Photoshop, InDesign, and Illustrator. These programs have plenty of cross-platform functionality, allowing you to transfer assets between projects, so you can make the most of each program's feature set. For example, you may want to import a Photoshop file (with the .PSD extension) into InDesign, so that you can use the image in a newspaper or magazine layout. 

Below, we've shared how to convert PSD to InDesign (with the .INDD extension), so you can work seamlessly between the two programs.

1. First, launch a new or existing InDesign project. If you're starting a new project, choose "Document" from the list of options, and then click OK. 

2. Next, choose "File" > "Place" from the top menu and locate your PSD file in the directory. Double-click on the file to load it into your InDesign document. You can also use traditional "copy" and "paste" commands to copy a PSD file into InDesign, but this embeds it into your document, so it won't be linked to the original file. That means if you adjust the PSD file in Photoshop during the creative process, the changes will not be updated to the InDesign version. 

3. When you're happy with the PSD placement, choose "File" > "Save As" to save a new version of your InDesign project. Even though a PSD file is featured prominently in the new project, it will still be saved in the .INDD format. 

4. Finally, if you're unhappy with the PSD file's resolution on your screen, you may want to adjust the display settings so that you can see more detail. Just choose "View" > "Display Performance" to adjust the settings. 
 
Managing Transparency and Clipping Paths
In Photoshop, it's common for layers to use transparency to service the final image. When you place a PSD file in InDesign, the program will analyze the transparency settings and import them. In fact, you can harness this transparency to create clipping paths in InDesign. Essentially, these invisible shapes can be used to mask sections of your image, so they aren't visible in the final InDesign project. 

  • Was this article helpful?

Can’t find what you’re looking for?