Videos with Alpha Channels

What are alpha channels?
Alpha channels are used to create videos that contain elements that are partially or completely transparent. These assets are often used when compositing a video together using multiple layers. An alpha channel is an additional layer of information that assigns a transparency value to each pixel in a video. This allows portions of a video’s frame to be partially or entirely transparent. Videos with alpha channels are used frequently when compositing videos using multiple layers.

Using Assets with Alpha Channels in Your Projects
Videos with alpha channels can be really valuable assets in creative projects, and can be integrated with your other assets seamlessly. Some codecs support alpha channels, and others don't. However, if you're creating videos with alpha channels, there's an easy way to incorporate these assets into your project, regardless of filetype, using mattes. If you’ve ever come across a black and white cutout-style duplicate attached to the end of the video, that was a luma matte.

The web and low resolution of videos with alpha channels will not contain the alpha channel - only the HD and 4K versions will.

Using Videos with Alpha Channels
Below are instructions on how to take videos with luma mattes and turn them into assets with functional alpha channels. We’ll be showing you how to accomplish this in Adobe Premiere, Adobe After Effects, and Final Cut X.

*Note - This is only for videos that include a luma matte. Make sure you check for it before you download; this can usually be found in the keywords on the footage page.

Adobe Premiere Pro

  1. Add your Shutterstock video clip into your project by clicking File > Import, or using the keyboard shortcut ⌘I.

  2. Double click on the video to open it within the Source Video Panel. Mark your In Point at the beginning of your video. Scrub through the video until you get to the end of the actual video and the beginning of the matte. (This is usually exactly halfway through the video.)  Set this frame as your Out Point. Drag the clip to the timeline in Layer 2.

  3. Advance the Source Video Panel one frame, to the start of the matte. Select this as your In Point. Scrub to the end of the video and select your Out Point. Drag this clip to the timeline in Layer 3, directly on top of the last clip. Now, if you scrub through your video in the Program Monitor Panel, you should see nothing but the matte.

  4. Go into the Effects Panel. Select Video Effects > Keying > Track Matte Key. Drag the Track Matte Key Effect onto the video in Layer 1.

  5. With the video in Layer 1 selected, go to the Effect Controls panel. You should see the effect Track Matte Key with two dropdown menus, one labeled ‘Matte’, one labeled ‘Composite Using’. In the ‘Matte’ dropdown, select the layer containing the video’s matte. In the ‘Composite Using’ dropdown, select Matte Luma.

The matte should disappear, leaving behind the video. To make sure the effect was successful, drop an asset into Layer 1. The transparent elements of the clip in Layer 2 should reveal the asset in Layer 1. If the effect does not appear to be working, try selecting the ‘Reverse’ checkbox in the Effect Controls panel.

Congratulations on using a Luma Matte to create a transparency effect!

Adobe After Effects

  1. Add your Shutterstock video clip into your project by clicking File > Import > Import File, or using the keyboard shortcut ⌘I.

  2. Create a New Composition from the clip by dragging the clip to the ‘New Composition’ icon, or right clicking and selecting ‘New Comp from Selection’.

  3. Select the clip’s layer in the timeline and duplicate it by clicking Edit > Duplicate, or using the keyboard shortcut ⌘D. You should now have two layers. With the top layer selected, hit enter and rename the layer ‘Matte’. Select the bottom layer and rename it ‘Video’.

  4. With the Matte layer selected, scrub through the video until you get to the end of the actual video and the beginning of the matte. With the first frame of the matte selected, trim the layer by using the keyboard shortcut Alt/Opt [. This will grey out everything before this frame, leaving just the matte.

  5. Drag the matte layer to the beginning of the composition. Now the matte should overlay the video.

  6. With the Video layer selected, scrub through the video until you get to the end of the actual video and the beginning of the matte. With the last frame of the video selected, trim the layer by using the keyboard shortcut Alt/Opt ]. This will grey out everything after this frame, leaving just the video.

  7. In the timeline objects panel, there are a number of checkboxes and dropdowns for each layer, including one labeled ‘TrkMat’. If you do not see this option available, right click on the ‘Layer Name’ heading and select Columns > Modes; this will bring up the ‘TrkMat’ column. With the Video layer selected, click on the ‘TrkMat’ dropdown menu and select ‘Luma Matte “Matte”’.

The matte should disappear, leaving behind the video. To make sure the effect was successful, drop an asset below your Video layer. The transparent elements of the clip should reveal the asset beneath it. If the effect does not appear to be working, try selecting the ‘Luma Inverted Matte’ option from the ‘TrkMat’ dropdown.

Congratulations on using a Luma Matte to create a transparency effect!

Final Cut Pro X

  1. Add your Shutterstock video clip into your event by clicking File > Import > Media, or using the keyboard shortcut ⌘I.

  2. In the browser, mark your In Point at the beginning of your video. Scrub through the video until you get to the end of the actual video and the beginning of the matte (this is usually exactly halfway through the video). Set this frame as your Out Point. Drag the clip to the timeline.

  3. Advance the browser one frame, to the start of the matte. Select this as your In Point. Scrub to the end of the video and select your Out Point. You should now have the matte selected. Drag the matte to the timeline directly beneath the video clip. Now, when you scrub through the timeline, only the video should be visible in the Viewer Window, not the matte.

  4. Select the Video layer and change its Blend Mode to ‘Behind’. This is located at the bottom of the Inspector, within the Compositing Options. The video in the Viewer should disappear, leaving the Matte behind.

  5. Select the Matte layer and change its Blend Mode to ‘Silhoutte Luma’.  

The matte should disappear, leaving behind the video. To make sure the effect was successful, drop an asset below your Matte layer. The transparent elements of the clip should reveal the asset beneath it. If the effect does not appear to be working, try changing the Matte layer’s Blend Mode to ‘Stencil Luma’.  

Congratulations on using a Luma Matte to create a transparency effect!

  • Was this article helpful?

Can’t find what you’re looking for?