How can I "vectorize" an image?

Bitmap Vs. Vector Images 
Most images in their native state are raster images, or bitmap images. These images utilize rows and columns of pixels made of different colors to render the image. Bitmap images are quite common (.JPEG, .PNG, etc) and are fairly easy to understand.
 
Bitmap images, due to their expression via bitmap, are resolution-dependent. If you need to resize a bitmap image you will reduce the quality of the image. Resizing the image to be smaller forces you to get rid of pixels, and if you increase size the lines and curves become jagged and defined by a clear gradient.


Need editable vector graphics? Shutterstock has millions!
Our collection is waiting for you; begin exploring now.

Vector images solve this issue of resizing images. Vector images are path-based – they are composed of mathematical equations so the image itself is easily scalable. Because of this, vector images are considered resolution independent. Vector images have a specific artificiality to them because they are completely computer-generated. They’ll never look photo-realistic. However one can individually resize and retool specific shapes and components of vector images without destroying the image itself. This makes vector images very useful for graphic designers.
 
How to Convert Images to Vectors
Due to these factors, often designers will choose to vectorize an image, or convert it from a bitmap (.JPEG, .PNG) to a vector-based image. The opposite process, turning an image into a bitmap, is called rasterizing. The two most common programs used to convert bitmap images into vector images are Photoshop and Illustrator.
 
How to Vectorize an Image in Photoshop
When you use Adobe Photoshop, the images you’re manipulating are bitmap images by default. Follow these steps to convert bitmap images in Photoshop into vector images. 

  1. Open the “Window” menu and select “Paths” to pull up the corresponding panel. You have three choices in the options bar: select the standard Pen tool to create straight lines and Bezier curves over the image. Select the Freeform option for a more organic and loose drawing that you trace over the image. Select the Magnetic Pen to follow transitions of color and brightness within the image.

  2. Draw your vector paths over the image until you have a traced conversion of the paths and shapes within your image. Press Enter when you are done tracing a path to signal the end of the pathway.

  3. Select further pathways utilizing the Lasso, Marquee, and Magic Wand selection tools. Click the menu button at the top right corner of the “Paths” panel and choose “Make Work Path” to turn each selection into a vector pathway.

  4. Set the tolerance level for the pathways. Smaller levels make the path adhere tightly to what you’ve traced, while larger levels displays smooth transitions between anchor points in your path.

  5. When you create a new work path be sure to double click the Path name that appears in the “Paths” panel. Accept the default name or name each path. Otherwise new actions will replace vector drawings on the work path with new output.

  6. Export vector paths from Photoshop into Illustrator so you can use them across other programs. Click “File” à “Export” à “Paths to Illustrator.”

How to Vectorize an Image in Illustrator 
Illustrator is an application made by Adobe that is used to create vector images. Because vector images are the native format, vectorizing images within Illustrator is fairly straightforward. You’ll be using the Live Trace functions to create paths.

  1. Open the image in Illustrator and make sure it’s selected.

  2. Navigate to the “Live Trace” option on the control panel. Click the “Tracing Presets and Options” menu icon next to it.

  3. Browse the existing preset options and select one to vectorize the image. For example, selecting “16 Colors” will vectorize the image in 16 separate colors.

  4. In order to create a separate path for each color click “Expand” under the options menu.

  5. To customize the settings for each path, navigate to the “Tracing Presets and Options” menu and click “Tracing Options.” From here you can edit settings such as “Mode,” “Blur” and “Threshold.”

  6. Click “Preview” to view the resulting vector images. Using this tool you can modify the paths as needed and experiment with the settings before saving the image.

  • Was this article helpful?

Can’t find what you’re looking for?