画像をベクター化する方法

ビットマップ画像とベクター画像の比較
自然な状態の画像の多くはラスター画像、つまりビットマップ画像です。これらの画像は、異なる色のピクセルの行と列を使用して画像を描画します。ビットマップ画像は非常に一般的で(.JPEG、.PNGなど)、理解するのは難しくありません。

ビットマップ画像は、ドット(ビットマップ)で表現されるため解像度に依存します。ビットマップ画像のサイズを変更すると、画質が低下します。画像のサイズを小さくするとピクセルがなくなり、サイズを大きくすると線やカーブがシャギー状態になります。この状態では完全な階調で表現されます。


編集可能なベクターグラフィックが必要ですか?Shutterstockには数百万ものグラフィックがあります。
膨大なコレクションをいつでもご覧になれます。今すぐ探し始めてください

ベクター画像は画像のサイズ変更の問題を解決します。ベクター画像はパスベースです。数学的な方程式で構成されているため、画像自体を容易にサイズ変更できます。このため、ベクター画像は解像度に依存しないと言うことができます。コンピュータで生成されるベクター画像は明らかに人工的で、決して写真のようにリアルに見えませんが、画像自体を壊すことなく、ベクター画像の特定の形状や構成要素を個別にサイズ変更および再調整することができます。そのため、ベクター画像はグラフィックデザイナーにとって非常に便利です。

ベクター化
これらの特性により画像のベクター化、つまりビットマップからベクターベースに変換する方法が頻繁に使用されています。画像をビットマップに変換する反対のプロセスは、ラスター化と呼ばれます。ビットマップ画像のベクター画像への変換に使用される最も一般的なプログラムは、PhotoshopIllustratorの2つです。

Photoshopで画像をベクター化する方法
Adobe Photoshopを使用する場合、操作する画像はデフォルトでビットマップ画像になります。 Photoshopのビットマップ画像をベクター画像に変換するには、次の手順に従います。 

  1. [Window]メニューを開き、[Paths]を選択して、対応するパネルをプルアップします。オプションバーには3つの選択肢があります:画像上に直線とベジェ曲線を作成するには、標準の[Pen]ツールを選択します。画像をトレースしてもっと有機的でゆるやかに描画する場合は、[Freeform]オプションを選択します。画像内の色と明るさの変化を追うには、[Magnetic Pen]を選択します。

  2. 画像上にベクターパスを描画し、画像内のパスとシェイプをトレースした変換を作成します。パスのトレース終了後は、Enterキーを押してパスの終了を確定します。

  3. 選択ツール[Lasso]、[Marquee]、[Magic Wand]を使用して、さらにパスを選択します。[Paths]パネルの右上にあるメニューボタンをクリックし、[Make Work Path]を選択して、各選択をベクターパスに変換します。

  4. パスの許容レベルを設定します。小さなレベルでは、トレースにパスがしっかりと密着しますが、大きなレベルではパスのアンカーポイント間のスムーズな移行が表示されます。

  5. 新しいワークパスを作成する場合は、[Paths]パネルに表示されるパス名をダブルクリックします。デフォルト名を使用する、または各パスに新たに名前を付けます。各パスの名前を確定しないと、ワークパス上のベクター描画が新しいワークパスで置き換えられます。

  6. PhotoshopからIllustratorにベクターパスをエクスポートして、他のプログラムで使用することができます。 [File]à[Export]à[Paths to Illustrator]をクリックします。

Illustratorで画像をベクター化する方法
Illustratorは、ベクター画像の作成に使用されるAdobeのアプリケーションです。Illustratorではベクター画像をベースにしているため、画像のベクター化はとても簡単です。[Live Trace]機能を使用してパスを作成します。

  1. Illustratorで画像を開き、選択されていることを確認します。

  2. コントロールパネルの[Live Trace]オプションに移動します。その横の[Tracing Presets and Options]メニューアイコンをクリックします。

  3. 画像をベクター化する既存のプリセットオプションの1つを選択します。たとえば、[16 Colors]を選択すると、16色で画像がベクター化されます。

  4. 色ごとに別々のパスを作成するには、オプションメニューの下にある[Expand]をクリックします。

  5. 各パスの設定をカスタマイズするには、[Tracing Presets and Options]メニューに移動し、[Tracing Options]をクリックします。ここから、[Mode]、[Blur]、[Threshold]などの設定を編集できます。

  6. 結果のベクター画像を表示するには、[Preview]をクリックします。このツールを使用すると、必要に応じてパスを修正して画像を保存する前に設定を試すことができます。

  • この記事は役に立ちましたか?

お探しのものが見つかりませんか?