Videa s alfa kanály

Co to jsou alfa kanály?
Alfa kanály se používají k vytváření videí obsahujících částečně nebo zcela průhledné prvky. Takovéto obrázky se často používají při vytváření videa za použití několika vrstev. Alfa kanál představuje další vrstvu s informacemi poskytujícími parametry průhlednosti pro každý pixel videa. Takto lze určitou část snímků videa zčásti nebo zcela zprůhlednit. Videa s alfa kanály se často používají při tvorbě videí s několika vrstvami.

Použití produktů s alfa kanály v projektech
Videa s alfa kanály mohou být opravdu cenným prvkem v kreativních projektech a lze je snadno začlenit do dalších obrázků. Některé kodeky podporují alfa kanály, a jiné ne. Pokud však vytváříte video pomocí alfa kanálů, existuje jednoduchý způsob začlenění těchto produktů do vašeho projektu, bez ohledu na typ souboru či použití masek (matte). Pokud jste se někdy setkali s černobílým duplikátem ve stylu výřezu, který byl připojen ke konci videa, pak se jednalo o luma masku (luma matte).

Webové stránky a videa s nízkým rozlišením s alfa kanály nebudou obsahovat alfa kanál - pouze verze HD a 4K.

Používání videí s alfa kanály
Níže uvádíme pokyny pro vytváření videí s maskami luma matte a jejich přeměnu na produkty s funkčními alfa kanály. Ukážeme vám, jak toho dosáhnout v aplikacích Adobe Premiere, Adobe After Effects a Final Cut X.

*Poznámka - Toto platí pouze pro videa, která obsahují masku luma matte. Před stažením si je zkontrolujte. Tuto informaci lze obvykle nalézt v klíčových slovech na stránce videoklipu.

Adobe Premiere Pro

  1. Přidejte svůj videoklip Shutterstock do projektu klepnutím na File > Import nebo pomocí klávesové zkratky ⌘I.

  2. Poklepáním na video jej otevřete v panelu zdrojového videa. Označte vstupní bod na začátku videa. Projděte videem, dokud se nedostanete na jeho konec a na začátek masky. (Ta se obvykle nachází přesně v polovině videa.) Nastavte tento snímek jako výstupní bod. Přetáhněte videoklip na časovou osu do vrstvy 2.

  3. Posuňte panel zdrojového videa o jeden snímek na začátek masky. Zvolte jej jako vstupní bod. Přejděte na konec videa a vyberte výstupní bod. Přetáhněte tento videoklip na časovou osu do vrstvy 3, přímo do horní vrstvy posledního videoklipu. Nyní, pokud budete procházet video v panelu Program Monitor, měli byste vidět pouze masku.

  4. Přejděte k panelu Effects. Vyberte funkci Video Effects > Keying > Track Matte Key. Přetáhněte efekt Track Matte Key do vrstvy 1 ve videu.

  5. Ze zvolené vrstvy 1 videa přejděte na panel Effect Controls. Zobrazí se efekt Track Matte Key se dvěma rozbalovacími nabídkami, jedna bude označena Matte, a druhá Composite Using. V rozbalovací nabídce Matte vyberte vrstvu obsahující video s maskou. V rozbalovací nabídce Composite Using zvolte možnost Matte Luma.

Maska zmizí a zůstane video. Chcete-li se přesvědčit o úspěšnosti použití efektu, přetáhněte obrázek do vrstvy 1. Průhledné prvky klipu ve vrstvě 2 odkryjí obrázky ve vrstvě 1. Pokud se vám zdá, že efekt nefunguje, zkuste vybrat zaškrtávací políčko Reverse v panelu Effect Controls.

Blahopřejeme vám k použití Luma Matte a vytvoření průhledného efektu.

Adobe After Effects

  1. Přidejte svůj videoklip Shutterstock do projektu klepnutím na File > Import > Import File nebo pomocí klávesové zkratky ⌘I.

  2. Vytvořte novou kompozici z videoklipu přetažením videoklipu do ikony New Composition nebo klepnutím pravým tlačítkem a výběrem položky New Comp from Selection.

  3. Vyberte vrstvu videoklipu v časové ose a duplikujte ji klepnutím na tlačítko Edit > Duplicate nebo pomocí klávesové zkratky ⌘D. Nyní byste měli mít dvě vrstvy. Při výběru horní vrstvy stiskněte tlačítko Enter a přejmenujte vrstvu Matte. Vyberte spodní vrstvu a přejmenujte ji na Video.

  4. Vyberte vrstvu Matte a procházejte videem, dokud se nedostanete na jeho konec a na začátek masky. Vyberte první snímek vybrané masky a ořízněte vrstvu pomocí klávesové zkratky Alt/Opt [. Vše před tímto obrázkem změní barvu na šedou a zůstane pouze maska.

  5. Přetáhněte vrstvu masky na začátek kompozice. Nyní maska překrývá video.

  6. Vyberte vrstvu Video a procházejte videem, dokud se nedostanete na jeho konec a na začátek masky. Vyberte poslední snímek vybraného videa a ořízněte vrstvu pomocí klávesové zkratky Alt/Opt ]. Vše za tímto obrázkem změní barvu na šedou a zůstane pouze video.

  7. V panelu objektů časové osy se nachází řada zaškrtávacích políček a rozbalovacích položek pro každou vrstvu, včetně funkce označené TrkMat. Pokud tuto možnost nevidíte, klepněte pravým tlačítkem myši na funkci Layer Name a vyberte možnost Columns > Modes; tím otevřete možnost TrkMat. Vyberte vrstvu Video, klepněte na rozbalovací nabídku funkce TrkMat a vyberte masku Luma Matte.

Maska zmizí a zůstane video. Chcete-li se přesvědčit o úspěšnosti použití efektu, přetáhněte obrázek pod vrstvu Video. Průhledné prvky videoklipu odhalí obrázky pod ním. Pokud se vám zdá, že efekt nefunguje, zkuste v rozbalovací nabídce TrkMat vybrat možnost Luma Inverted Matte.

Blahopřejeme vám k použití Luma Matte a vytvoření průhledného efektu.

Aplikace Final Cut Pro X

  1. Přidejte svůj videoklip Shutterstock do projektu klepnutím na File > Import > Media nebo pomocí klávesové zkratky ⌘I.

  2. Ve vyhledávači označte vstupní bod na začátku videa. Projděte videem, dokud se nedostanete na jeho konec a na začátek masky (zpravidla v polovině videa). Nastavte tento záběr jako výstupní bod. Přetáhněte videoklip na časovou osu.

  3. Posuňte vyhledávač o jeden snímek na začátek masky. Zvolte jej jako vstupní bod. Přejděte na konec videa a vyberte výstupní bod. Nyní vyberte masku. Přetáhněte masku na časovou osu přímo pod videoklip. Pokud nyní procházíte časovou osou, zobrazí se v okně prohlížeče pouze video, maska nikoliv.

  4. Vyberte vrstvu Video a upravte její režim Blend Mode na Behind. Tuto možnost najdete v dolní části možnosti Inspector v části Compositing Options. Video z prohlížeče zmizí a zůstane maska.

  5. Vyberte vrstvu Matte a upravte její režim Blend Mode na Silhoutte Luma.  

Maska zmizí a zůstane video. Chcete-li se přesvědčit o úspěšnosti použití efektu, přetáhněte obrázek pod vrstvu Matte. Průhledné prvky videoklipu odhalí obrázky pod ním. Pokud se vám zdá, že efekt nefunguje, zkuste upravit Blend Mode masky na Stencil Luma.  

Blahopřejeme vám k použití Luma Matte a vytvoření průhledného efektu.

  • Pomohl vám tento článek?

Nedaří se vám najít to, co hledáte?